package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|\W|\b)"@(\W|\b|$)`)
var str = `"@#bar {}qux`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}