Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(VI[0-9]{4}(?:BV)?(?:\d{2})?(D|H|MIN|MAX)?)+$
/
gm
Input 1
1
New
6789 VI2111 VI2122 VI2122MIN VI2122MAX VI2122MUN VI210021 VI210021D VI210021H VI210021X VI2100BVMIN VI2100BVMAX VI2100 VI21001