use strict;
my $str = '1231231223123131_FILE_NAME.EXTENSION.OTHEREXTENSION
1_This_is_an_otherExample.mpg.OTHEREXTENSIONadasdassdassds34
1231231223123131_myFile.tar.gz2';
my $regex = qr/([a-zA-Z][a-zA-Z_]*\.[a-zA-Z]+)/mp;
my $subst = '\\1.\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";