#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((.*(\\|\/))*\.settings(.*(\\|\/))*.*)|((.*(\\|\/))*\.metadata(.*(\\|\/))*.*)|(exe|war|ear|class|zip|7z|iso|tar|car|dll)$"
Local $sString = ".settings" & @CRLF & _
"abc\.settings" & @CRLF & _
"abc/.settings" & @CRLF & _
"abc.class" & @CRLF & _
"adb.ear" & @CRLF & _
"abd.war" & @CRLF & _
"abc.jar" & @CRLF & _
"asc.sa" & @CRLF & _
"abc/.metadata\abc.ear" & @CRLF & _
"abc/.settings\abc.ear" & @CRLF & _
".settings" & @CRLF & _
".metadata" & @CRLF & _
".classpath" & @CRLF & _
"abc/xyz/ac.zip" & @CRLF & _
"abc.classpath" & @CRLF & _
"abc/classpath/.classpath/abc" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")