const regex = /(\d+)\s+(\w{5})\s+(.+)\s+(\$[\d.]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s+(\\w{5})\\s+(.+)\\s+(\\$[\\d.]+)', 'g')
const str = `Qty. Model Code Instrument/department/model/Vision Make&Model,etc. T&A Charge
82 34ARE Guitar bag \$154
22 A4314 play Bag and zipper \$409.80`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}