using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"UserRoleCode:(?<UserRoleCode>\d+) UserRoleText:(?<UserRoleText>\w+)";
string input = @" [1]UserRoleCode:1 UserRoleText:Admin
[2]UserRoleCode:2 UserRoleText:Developer";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}