package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)UserRoleCode:(?<UserRoleCode>\d+) UserRoleText:(?<UserRoleText>\w+)`)
var str = ` [1]UserRoleCode:1 UserRoleText:Admin
[2]UserRoleCode:2 UserRoleText:Developer`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}