import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "UserRoleCode:(?<UserRoleCode>\\d+) UserRoleText:(?<UserRoleText>\\w+)";
final String string = " [1]UserRoleCode:1 UserRoleText:Admin\n"
+ " [2]UserRoleCode:2 UserRoleText:Developer";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}