const regex = /UserRoleCode:(?<UserRoleCode>\d+) UserRoleText:(?<UserRoleText>\w+)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('UserRoleCode:(?<UserRoleCode>\\d+) UserRoleText:(?<UserRoleText>\\w+)', 'gms')
const str = ` [1]UserRoleCode:1 UserRoleText:Admin
[2]UserRoleCode:2 UserRoleText:Developer`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}