re = /UserRoleCode:(?<UserRoleCode>\d+) UserRoleText:(?<UserRoleText>\w+)/m
str = ' [1]UserRoleCode:1 UserRoleText:Admin
[2]UserRoleCode:2 UserRoleText:Developer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end