# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\sgroup\:\s['\"](.*)['\"],\sname\:\s['\"](.*)['\"],\sversion\:\s['\"](.*)['\"]|(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\s['\"](.*):(.*):(.*)['\"]|(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\(['\"](.*):(.*):(.*)['\"]\)"
test_str = ("compile group: 'commons-net', name: 'commons-net', version: '3.1.2'\n"
"testCompile group: 'org.spockframework', name: 'spock-core', version: '2.0-M1-groovy-3.0'\n"
"implementation group: 'commons-net', name: 'commons-net', version: '3.7.2'\n"
"testImplementation group: 'org.spockframework', name: 'spock-core', version: '2.0-M4-groovy-3.0'\n"
"implementation \"org.apache.httpcomponents:httpclient:latest.release\"\n"
"implementation 'org.apache.httpcomponents:httpclient:1.0.0'\n"
"compile \"com.h2database:h2:1.4.197\"\n"
"compile(\"com.github.bkenn:kfoenix:0.1.2-SNAPSHOT\")\n"
"compile group: \"com.jfoenix\", name: \"jfoenix\", version: \"8.0.7\"\n"
"compile \"org.jooq:jooq:3.11.5\"\n"
"jooqRuntime('com.h2database:h2:1.4.197')\n"
"jooqRuntime(\"com.h2database:h2:1.4.197\")\n"
"jooqRuntime 'com.h2database:h2:1.4.197'\n"
"jooqRuntime \"com.h2database:h2:1.4.197\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.