$re = '/^(?:\d{2}-\d{3}-\d{3}-\d{3}|\d{11})$/m';
$str = '46123456789
46-123-456-789
46-123-456-789
+46-123-456-789
+46123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);