// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{2}-\d{3}-\d{3}-\d{3}|\d{11})$").unwrap();
let string = "46123456789
46-123-456-789
46-123-456-789
+46-123-456-789
+46123456789";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}