#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+(?:\s*\|+\s*\w+\s*)*$"
Local $sString = "COMMENT — CODE | COUNTRY | DATE | TARGET" & @CRLF & _
"CODE| COUNTRY | DATE |TARGET" & @CRLF & _
"CODE|| COUNTRY| DATE |TARGET" & @CRLF & _
"COMMENT 1 — COMMENT 2 — CODE | COUNTRY | DATE | TARGET"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")