import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+:\\K\\w.*";
final String string = "this string should not match\n\n"
+ "bob_1:Hi. I'm Bob. I speak русский and this string should match \n\n"
+ "alice:Hi Bob. I speak 한국어 and this string should also match\n\n"
+ "http://example.com - would prefer to not match URLs\n\n"
+ "This string:should not match because no spaces or capital letters are allowed left of the colon";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}