using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\()?(\d{3})(?(1)\)|)([\.\s-])?(\d{3})(?(3)[\.\s-]|[\.\s-]?)(\d{4})";
string input = @"123 456 7890 (123) 456-7890 (123)456-7890 123 456 7890 123.456.7890 (blank/null) 1234567890";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}