$re = '/(\()?(\d{3})(?(1)\)|)([\.\s-])?(\d{3})(?(3)[\.\s-]|[\.\s-]?)(\d{4})/m';
$str = '123 456 7890 (123) 456-7890 (123)456-7890 123 456 7890 123.456.7890 (blank/null) 1234567890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);