#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)vertex.+\s[0-9\.]*[1-9][0-9\.]*$"
Local $sString = "facet normal -1.000000 0.000000 0.000000" & @CRLF & _
"outer loop" & @CRLF & _
"vertex 26.000000 6.000000 0.000000" & @CRLF & _
"vertex 26.000000 6.000000 -1.000000" & @CRLF & _
"vertex 26.000000 7.000000 1.000000" & @CRLF & _
"endloop" & @CRLF & _
"endfacet" & @CRLF & _
"facet normal -1.000000 0.000000 0.000000" & @CRLF & _
"outer loop" & @CRLF & _
"vertex 26.000000 6.000000 0.000000" & @CRLF & _
"vertex 26.000000 7.000000 1.000000" & @CRLF & _
"vertex 26.000000 7.000000 0.000000" & @CRLF & _
"endloop" & @CRLF & _
"endfacet" & @CRLF & _
"facet normal 0.000000 1.000000 0.000000" & @CRLF & _
"outer loop" & @CRLF & _
"vertex 26.000000 7.000000 0.000100" & @CRLF & _
"vertex 26.000000 7.000000 1.000000" & @CRLF & _
"vertex 27.000000 7.000000 1.000000" & @CRLF & _
"endloop" & @CRLF & _
"endfacet" & @CRLF & _
"endsolid "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")