import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "first=([^&]*)";
final String string = "http://www.example.com.tr/?first=DSPN47ZTE1BGMR&second=NECEFT8RYD\n"
+ "http://www.example.com.tr/?first=RTR22414242144&second=YUUSADASFF\n"
+ "http://www.example.com.tr/?first=KOSDFASEWQESAS&second=VERERQWWFA\n"
+ "http://www.example.com.tr/?first=POLUJYUSD41234&second=13F241DASD\n"
+ "http://www.example.com.tr/?first=54SADFD14242RD&second=TYY42412DD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}