re = /^(10(\.(1?\d\d?|2([0-4]\d?|5[0-5])))(?2)|172\.(1[6-9]|2\d|3[0-2])(?2)|192\.168(?2))(?2)$/m
str = '10.17.0.1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end