#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+)%"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
""1%"" & @CRLF & _
"" & @CRLF & _
""10%""
Local $sSubst = "$1.0%"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)