re = /(^([0-9]{2,3}.)([0-9]{2,3}.)([0-9]{2,3}.)([0-9]{2,3})$)/m
str = '00.123.55.44
000.12.12.034
121.234.12.12
23.45.12.56
00.12.123.123123.123
122.23
Hello.IP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end