import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{1,2}\\/[a-zA-Z]-[0-9]\\/[A-Z]+\\/([0-9.]+\\/)?[0-9]+$";
final String string = "11/A-9/XI/2015\n"
+ "12/A-9/XII/2.99/2015\n"
+ "12/A-9/XII/2.99/a2015\n"
+ "a12/A-9/XII/2.99/2015\n"
+ "12/A-9/XII/2.99/2015a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}