#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:(?:\(?(?:00|\+)([1-4]\d\d|[1-9]\d?)\)?)?[\-\.\ \\\/]?)?((?:\(?\d{1,}\)?[\-\.\ \\\/]?){0,})(?:[\-\.\ \\\/]?(?:#|ext\.?|extension|x)[\-\.\ \\\/]?(\d+))?$"
Local $sString = "(+44) 7 9349394 349893" & @CRLF & _
"07810640611" & @CRLF & _
"+447542156663" & @CRLF & _
"0162611111" & @CRLF & _
"01245" & @CRLF & _
"01 265 457 789 1 11" & @CRLF & _
"sgrxdrxg dr" & @CRLF & _
"7498ghdxrg" & @CRLF & _
"78974756456451321546547984645"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")