package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https://[^/]+/(.*)`)
var str = `https://example.com/`
var substitution = "https://test.com/$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}