using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:(?>(.{1,5})(?:(?<=[^\S\r\n])[^\S\r\n]?|(?<=[,.;:!\/?])|(?=\r?\n|[-#%&*@_])|[^\S\r\n]))|(.{1,5}))(?:\r?\n)?|(?:\r?\n))";
string substitution = @"$1$2\r\n";
string input = @"To be or not to be-that is the question";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}