import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:(?>(.{1,5})(?:(?<=[^\\S\\r\\n])[^\\S\\r\\n]?|(?<=[,.;:!\\/?])|(?=\\r?\\n|[-#%&*@_])|[^\\S\\r\\n]))|(.{1,5}))(?:\\r?\\n)?|(?:\\r?\\n))";
final String string = "To be or not to be-that is the question";
final String subst = "$1$2\\r\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}