const regex = /(?:(?:(?>(.{1,5})(?:(?<=[^\S\r\n])[^\S\r\n]?|(?<=[,.;:!\/?])|(?=\r?\n|[-#%&*@_])|[^\S\r\n]))|(.{1,5}))(?:\r?\n)?|(?:\r?\n))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:(?>(.{1,5})(?:(?<=[^\\S\\r\\n])[^\\S\\r\\n]?|(?<=[,.;:!\\\/?])|(?=\\r?\\n|[-#%&*@_])|[^\\S\\r\\n]))|(.{1,5}))(?:\\r?\\n)?|(?:\\r?\\n))', 'g')
const str = `To be or not to be-that is the question`;
const subst = `$1$2\r\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);