# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:(?>(.{1,5})(?:(?<=[^\S\r\n])[^\S\r\n]?|(?<=[,.;:!\/?])|(?=\r?\n|[-#%&*@_])|[^\S\r\n]))|(.{1,5}))(?:\r?\n)?|(?:\r?\n))"
test_str = "To be or not to be-that is the question"
subst = "$1$2\\r\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.