const regex = new RegExp('([^\\W\\d_])(\\d)', 'gmu')
const str = `سعید123`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);