use strict;
my $str = 'سعید123';
my $regex = qr/([^\W\d_])(\d)/mup;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";