#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^([a-z]+-[a-z]+[0-9]+-[a-z]+)$|^([a-z]+[0-9]+-[a-z]+[0-9]+-[a-z])$|^([a-z]+-[a-z]+-[a-z])$"
Local $sString = "aaa-b3-c" & @CRLF & _
"a3-b6-c" & @CRLF & _
"aaaa-bb-c" & @CRLF & _
"aaa-b3-c3" & @CRLF & _
"a3-1b6-c" & @CRLF & _
"aaaa-bb-c7"
Local $sSubst = "\1\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)