#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^{{\s?(?:\:{1,2}|!){1}\s?([a-zA-z0-9\.]+)\s?(?:\|\s?(\w+))?\s?}}$"
Local $sString = "{{ :: campaign_statuses.send }}" & @CRLF & _
"{{::campaign_statuses.send}}" & @CRLF & _
"" & @CRLF & _
"{{ :: campaign_statuses.send | number }}" & @CRLF & _
"{{::campaign_statuses.send|number}}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{{ ! 123123123 | number }}" & @CRLF & _
"{{!123123123|number}}" & @CRLF & _
"" & @CRLF & _
"{{ !>>::campaign.date_created | 123123123 | number }}" & @CRLF & _
"{{!>>::campaign.date_created123123123|number}}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")