$re = '/(Q[^a-zA-Z ]+)/m';
$str = 'Fellowes Folders, Blue
SanDisk Numeric Keypad, Bluetooth
Avery Legal,Q3-2024 Exhibit Labels, 5000 Label Set
Fellowes Folders, Wire Frame
Memorex Memory Card, USB
Rogers Shelving, Wire Frame
Apple Signal Q2/24 Booster, Full Size
Canon Personal Copier, Laser
Hoover Stove, Red
Accos Push Pins, Bulk Pack
Hon Color Coded Labels, Alphabetical
Hamilton Beach Stove, Silver
Binney & Q1-23 Smith Pens, Easy-Erase
Samsung Smart Phone, Full Size
Rogers Folders, Blue
Smead Trays, Wire Frame
Belkin Memory Card, USB
Hon Removable Labels, Adjustable
GlobeWeis Peel and Seal, Set of 50';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);