import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\\.[a-zA-Z]{2,4})";
final String string = "JakobCJakobsen@einrot.com+1 (845) 858-7707\n"
+ "johndoe@email.com1234567890\n"
+ "304-438-2648SandraCTaylor@dayrep.com\n"
+ "978-243-8596JuanPerez@teleworm.us\n"
+ "413-259-3637BuiQuynhChan@fleckens.hu\n"
+ "AlexCrawford@dayrep.com+1 (208) 264-9063\n"
+ "StefanijaNovosel@teleworm.us1 518 487 4865";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}