const regex = new RegExp('([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\\.[a-zA-Z]{2,4})', 'gm')
const str = `JakobCJakobsen@einrot.com+1 (845) 858-7707
johndoe@email.com1234567890
304-438-2648SandraCTaylor@dayrep.com
978-243-8596JuanPerez@teleworm.us
413-259-3637BuiQuynhChan@fleckens.hu
AlexCrawford@dayrep.com+1 (208) 264-9063
StefanijaNovosel@teleworm.us1 518 487 4865`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}