package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^:/]*[:/](*SKIP)(*F)|.+`)
var str = `small_animal/Mouse
BigAnimal:Elephant
Not an animal.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}