re = /^[^:\/]*[:\/](*SKIP)(*F)|.+/m
str = 'small_animal/Mouse
BigAnimal:Elephant
Not an animal.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end