// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+[1-9]\d{1,14}$").unwrap();
let string = "754-3010
(541) 754-3010
+1-541-754-3010
1-541-754-3010
+15417543010
001-541-754-3010
191 541 754 3010";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}