import Foundation
let pattern = #"""
^
(?!.*\b(\d+)\b.*\b\1\b)
(0?\d|[12][0-9]|3[01])
(,(0?\d|[12][0-9]|3[01]))*
$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
2,4,6,7,1
2,2,6
2
2,
1,2,3,4,15,6,7,31
1,2,3,4,15,6,7,32
20,15,3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)