import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^kalender) - .* - outlook";
final String string = "Kalender - user1@firma.de - outlook\n"
+ "Kalender - user1@company.com - outlook\n"
+ "Kalender - user2@company.com - outlook\n"
+ "Kalender - user3@company.com - outlook\n"
+ "inbox - user1@company.com - outlook\n"
+ "inbox - user2@company.com - outlook\n"
+ "inbox - user3@company.com - outlook\n"
+ "sent - user1@company.com - outlook\n"
+ "sent - user2@company.com - outlook\n"
+ "sent - user3@company.com - outlook\n"
+ "waiting - user1@company.com - outlook\n"
+ "waiting - user2@company.com - outlook\n"
+ "waiting - user3@company.com - outlook";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}