$re = '/^(\/BLOG\/Tags)(\/.+)\b/m';
$str = '/BLOG/Tags/Finereader-server/';
$subst = "/tag\L$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;