#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/([^\/]+)\/es(\/|$)"
Local $sString = "http://localhost:3000/es" & @CRLF & _
"http://localhost:3000/es/" & @CRLF & _
"http://localhost:3000/es/some-post" & @CRLF & _
"https://my-site.com/es" & @CRLF & _
"https://my-site.com/es/" & @CRLF & _
"https://my-site.com/es/some-post" & @CRLF & _
"https://random-domain.something/es" & @CRLF & _
"https://random-domain.something/es/" & @CRLF & _
"https://random-domain.something/es/some-post" & @CRLF & _
"" & @CRLF & _
"http://localhost:3000" & @CRLF & _
"http://localhost:3000/" & @CRLF & _
"http://localhost:3000/some-post" & @CRLF & _
"http://localhost:3000/es-some-post" & @CRLF & _
"https://my-site.com" & @CRLF & _
"https://my-site.com/" & @CRLF & _
"https://my-site.com/some-post" & @CRLF & _
"https://my-site.com/es-some-post" & @CRLF & _
"https://www.random-domain.something" & @CRLF & _
"https://www.random-domain.something/" & @CRLF & _
"https://www.random-domain.something/some-post" & @CRLF & _
"https://www.random-domain.something/es-some-post"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")