using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/([^\/]+)\/es(\/|$)";
string input = @"http://localhost:3000/es
http://localhost:3000/es/
http://localhost:3000/es/some-post
https://my-site.com/es
https://my-site.com/es/
https://my-site.com/es/some-post
https://random-domain.something/es
https://random-domain.something/es/
https://random-domain.something/es/some-post
http://localhost:3000
http://localhost:3000/
http://localhost:3000/some-post
http://localhost:3000/es-some-post
https://my-site.com
https://my-site.com/
https://my-site.com/some-post
https://my-site.com/es-some-post
https://www.random-domain.something
https://www.random-domain.something/
https://www.random-domain.something/some-post
https://www.random-domain.something/es-some-post";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}