const regex = /https?:\/\/([^\/]+)\/es(\/|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/([^\\\/]+)\\\/es(\\\/|$)', 'gm')
const str = `http://localhost:3000/es
http://localhost:3000/es/
http://localhost:3000/es/some-post
https://my-site.com/es
https://my-site.com/es/
https://my-site.com/es/some-post
https://random-domain.something/es
https://random-domain.something/es/
https://random-domain.something/es/some-post
http://localhost:3000
http://localhost:3000/
http://localhost:3000/some-post
http://localhost:3000/es-some-post
https://my-site.com
https://my-site.com/
https://my-site.com/some-post
https://my-site.com/es-some-post
https://www.random-domain.something
https://www.random-domain.something/
https://www.random-domain.something/some-post
https://www.random-domain.something/es-some-post`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}