use strict;
my $str = 'http://localhost:3000/es
http://localhost:3000/es/
http://localhost:3000/es/some-post
https://my-site.com/es
https://my-site.com/es/
https://my-site.com/es/some-post
https://random-domain.something/es
https://random-domain.something/es/
https://random-domain.something/es/some-post
http://localhost:3000
http://localhost:3000/
http://localhost:3000/some-post
http://localhost:3000/es-some-post
https://my-site.com
https://my-site.com/
https://my-site.com/some-post
https://my-site.com/es-some-post
https://www.random-domain.something
https://www.random-domain.something/
https://www.random-domain.something/some-post
https://www.random-domain.something/es-some-post';
my $regex = qr/https?:\/\/([^\/]+)\/es(\/|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}