# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?:\/\/([^\/]+)\/es(\/|$)"
test_str = ("http://localhost:3000/es\n"
"http://localhost:3000/es/\n"
"http://localhost:3000/es/some-post\n"
"https://my-site.com/es\n"
"https://my-site.com/es/\n"
"https://my-site.com/es/some-post\n"
"https://random-domain.something/es\n"
"https://random-domain.something/es/\n"
"https://random-domain.something/es/some-post\n\n"
"http://localhost:3000\n"
"http://localhost:3000/\n"
"http://localhost:3000/some-post\n"
"http://localhost:3000/es-some-post\n"
"https://my-site.com\n"
"https://my-site.com/\n"
"https://my-site.com/some-post\n"
"https://my-site.com/es-some-post\n"
"https://www.random-domain.something\n"
"https://www.random-domain.something/\n"
"https://www.random-domain.something/some-post\n"
"https://www.random-domain.something/es-some-post")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.