// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?:\/\/([^\/]+)\/es(\/|$)").unwrap();
let string = "http://localhost:3000/es
http://localhost:3000/es/
http://localhost:3000/es/some-post
https://my-site.com/es
https://my-site.com/es/
https://my-site.com/es/some-post
https://random-domain.something/es
https://random-domain.something/es/
https://random-domain.something/es/some-post
http://localhost:3000
http://localhost:3000/
http://localhost:3000/some-post
http://localhost:3000/es-some-post
https://my-site.com
https://my-site.com/
https://my-site.com/some-post
https://my-site.com/es-some-post
https://www.random-domain.something
https://www.random-domain.something/
https://www.random-domain.something/some-post
https://www.random-domain.something/es-some-post";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}