const regex = /(?!(^0+(\.0+)?$))^\d{1,4}(\.\d{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!(^0+(\\.0+)?$))^\\d{1,4}(\\.\\d{1,2})?$', 'gm')
const str = `0000.01
9999.99
1000.09
987.98
99888.82
9999
00.00
0000.00
000.0
000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}