package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`key: (.*);`)
var str = `something. key: value; something else`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}